acm的新手问题

来源:百度知道 编辑:UC知道 时间:2024/05/26 08:13:26
Problem Description
Your task is to Calculate a + b.

Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
2
1 5
10 20

Sample Output
6
30

怎么弄?
知道了。

#include<stdio.h>
int main()
{
int a,b,n;
scanf("%d",&n);
while(n--)
{
scanf("%d%d",&a,&b);
printf("%d\n",a+b);
}
return 0;
}

#include <stdio.h>
#include <malloc.h>

void main()
{
int i, n, a, b;
int *p;
scanf("%d", &n);
getchar();
p = malloc(n * sizeof(int));
for(i = 0; i < n; i++)
{
scanf("%d %d", &a, &b);
getchar();
p[i] = a + b;
}
for(i = 0; i < n; i++)
{
printf("%d\n", p[i]);
}
}

///c语言,毕业后没做acm有几年了,不知道能不能通过。。。似乎这是acm的第一题。。。