C语言程序设计 帮忙写出程序

来源:百度知道 编辑:UC知道 时间:2024/05/16 03:27:03
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
1 5
10 20
0 0
Sample Output
6
30

晕……没题目;只有输入说明而已啊
====================
太简单了吧……这是ACM的第一题吧……如果我没记错的话

C代码

#include <stdio.h>

int main()
{
int a,b;
while(1)
{
scanf("%d %d",&a,&b);
if(a==0 && b==0)
break;
printf("%d\n",a+b);
}
return 0;
}

C++代码
#include <iostream>
using namespace std;

int main()
{
int a,b;
while(1)
{
cin>>a>>b;
if(a==0 && b==0)
break;
cout<<a+b<<endl;
}
return 0;
}