hdu1005帮我看下我的代码在什么地方错了

来源:百度知道 编辑:UC知道 时间:2024/06/07 19:43:02
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

#include<stdio.h>
int main()
{
int a,b,n;
while(scanf("%d%d%d",&a,&b,&n)!=EOF&&(a+b+n)!=0)
{
int t=1,c[65]={0,1,1},i;
for(i=3;i<65;i++)
c[i]=(a*c[i-1]+b*c[i-2])%7;
for(i=3;i<65;i++)
if(c[1]==c[i]&&c[2]==c[i+1])
{
t=i-1;
break;
}
p

#include <iostream.h>
#include <string.h>
int main()
{
int A,B,n,i,j,c[200];
while(cin>>A>>B>>n&&n+A+B)
{
memset(c,0,sizeof(c));
c[1]=1;c[2]=1;
int temp=0;
for(i=3;i<=n;++i)
{
c[i]=( A*c[i-1]+B*c[i-2] )%7;
for(j=2;j<i;++j)
{
if(c[i]==c[j]&&c[i-1]==c[j-1])
{
temp=i-j;
break;
}
}
if(temp!=0)
{break;}
}
if(temp!=0)
cout<<c[(n-j)%temp+j]<<endl;
else
cout<<c[n]<<endl;
}
return 0;
}